Fraud API Service Degradation
Resolved
Jul 28 at 02:41am CEST
SEON APIs in the EU region experienced elevated latency and partial timeouts with the Fraud API between 00:00 and 00:04 UTC on Saturday, July 28, 2025, affecting less than 0.8% of requests. The issue has been resolved, and all systems are fully operational. We thank you for your patience and apologize for the inconvenience caused.
Affected services
REST Service - EU Region
Created
Jul 26 at 11:50pm CEST
SEON APIs in the EU region experienced elevated latency and partial timeouts with the Fraud API between 21:49 and 22:05 UTC on Saturday, July 26, 2025, affecting less than 1.5% of requests. The issue has been resolved, and all systems are fully operational. We thank you for your patience and apologize for the inconvenience caused.
Affected services
REST Service - EU Region