Planned Maintenance Update (EU)
Resolved
Oct 16 at 03:30am CEST
The planned SEON database maintenance has been successfully completed, and services are back to normal operation.
Thank you for your patience during the extended window!
Affected services
Created
Oct 16 at 12:00am CEST
We are continuing the scheduled maintenance on the SEON database to improve performance and security.
Please note: The original window (22:00ā01:00 UTC) has been extended to 04:00 UTC to complete the upgrade safely.
Expected impact:
- Temporary 5XX errors from the Fraud API (30sā5min)
- Short Admin Panel outages (30sā5min)
- Possible incomplete Fraud History and Geolocation responses
- Delayed alerts and notifications
All services will automatically resume normal operation once maintenance is complete.
Thank you for your patience and understanding.
Affected services