Back to overview
Downtime

SEON APIs experiencing performance degradation. Our team is working on the resolution.

Oct 20 at 10:09am CEST
Affected services
REST Service - US Region
Admin Panel - EU Region
Admin Panel - US Region

Resolved
Oct 21 at 12:01am CEST

We are pleased to inform you that the incident affecting SEON services has been resolved. All SEON services are now operating normally, and performance has returned to expected levels.

The disruption was caused by a global vendor operational issue, and we will continue to monitor the systems closely to ensure ongoing stability.

We sincerely appreciate your patience and understanding during this time, and we apologize for any inconvenience caused.

Updated
Oct 20 at 06:33pm CEST

We want to inform you that SEON is currently experiencing service degradation affecting the US environment. Response times and Dashboard performance may be slower due to an issue with a global vendor, who is actively investigating. We apologize for any inconvenience and appreciate your patience.

Updated
Oct 20 at 11:52am CEST

We are pleased to inform you that the issue affecting SEON services has been fully resolved. All SEON services are now operating normally, and performance has returned to expected levels.

The disruption was caused by a global vendor operational issue, which has now been addressed. We will continue to monitor the systems closely to ensure ongoing stability.

We sincerely appreciate your patience and understanding during this time, and we apologize for any inconvenience caused.

Created
Oct 20 at 10:09am CEST

Customers in SEON's US Service region may be experience performance degradation and higher than normal latencies. This is due to a global vendor's operational issue. Our vendor is investigating, and our team is working with them to resolve the issue as fast as possible